Status
Welcome to the Tenfold status page. We'll provide status of our services and updates here.
Degradation in telephony event process
Incident Report for Tenfold
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 17:30 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 10, 2020 - 16:38 UTC
Monitoring
Tenfold is aware of a cloud platform issue that might cause a degradation in performance to certain telephony control features such as Click to Dial.

At this point, we believe the situation has been resolved and we are monitoring
Posted Sep 10, 2020 - 16:38 UTC
This incident affected: Chrome Extension and API.