Identified - We have identified the root cause of the connection errors impacting the Salesforce integration popup. A recent update to Salesforce security policies requires Proof Key for Code Exchange (PKCE) parameters during the OAuth authentication flow. As a result, connection handshakes are currently being rejected by Salesforce, preventing call logging, screen pops, and record updates within the integration.
Next Steps: Our engineering team is actively making the required codebase updates to support PKCE authentication. We are in active communication with Salesforce to request a temporary exception while the update is finalized and tested.
ETA & Further Updates: We are currently completing internal testing and preparing the release for deployment.
We apologize for the disruption and appreciate your patience as we work to restore full service as quickly as possible.
Posted Jul 24, 2026 - 10:53 CDT
Update
We are actively working with Salesforce Support Engineering to resolve the issue. Initial investigations point to an anomaly during the authentication handshake between the systems.
Our team has completed an initial joint troubleshooting session with Salesforce to isolate the root cause. Their engineering team is currently analyzing the findings, and we are awaiting their confirmation on the next steps and remediation plan. We will provide another update as soon as new information is available.
Posted Jul 23, 2026 - 21:01 CDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2026 - 18:00 CDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2026 - 17:43 CDT
Investigating
Service Advisory: CRM Integration Issues
Status: Active Investigation
Impacted Feature: Company Settings -> CRM Tab
What’s Happening: We are currently tracking an issue affecting multiple accounts where users are encountering the following error message when attempting to access or authenticate their CRM settings:
invalid_grant - expired access/refresh token
invalid_grant - ip restricted by app developer
What We Are Doing: Our engineering team is actively investigating the root cause behind these token expirations. We are prioritizing a resolution to restore seamless connectivity as quickly as possible.
Action Required: At this time, no action is required on your end. We recommend holding off on repeated re-authentications of your CRM integration until we have resolved the underlying issue.
Next Update: We will provide another update as soon as we have more details, or within [e.g., 30–60 minutes]. Thank you for your patience.
Posted Jul 23, 2026 - 17:24 CDT
This incident affects: CRM Integrations (Salesforce).