Status
Welcome to the Tenfold status page. We'll provide status of our services and updates here.
Texas Winter Storm Impact and Escalation Plan
Incident Report for Tenfold
Resolved
We'd like to thank all of our Customers, Partners, and Vendors for having patience with our teams, as we navigated through what proved to be an extremely difficult week for members of our Tenfold Team (Family) located in Texas.

With all of the boil notices now being cleared and power restored in a majority if not all areas, we are now resolving this status page. Please continue to be patient with our teams as we catch-up on last week's events. Nevertheless, if you are not getting the support you need, please reach out to the leader directly as noted in the previous update.

--Tenfold Executive Leadership Team
Posted Feb 24, 2021 - 15:57 UTC
Monitoring
Dear Tenfold valued customer,

As a Texas company, we are experiencing a significant Winter Storm Warning, which has triggered the Texas state governing energy body to conserve power as the state's power grid strains from single-digit and below 0 temperatures and significant snow. Thus, we have employees experiencing rolling power outages, water shortages, and degraded mobile cell service.

Powered by a global service organization Tenfold has you covered, so rest assured all Tenfold systems and resources are currently active and our Technical Support team is available to assist as well. We just want to call your attention that we are assisting our employees in need and thus your normal routes of communication may not be available for the next few days. So if you are in need of anything please use our normal paths to connect with support as follows:

General (non-urgent) Support: Create a ticket at support.tenfold.com and we will get back to you in a timely fashion.

Urgent Support: To ensure you get anything and everything you need if your need is urgent and you would like to get in touch with a member of a given team, we have the following direct numbers for you to reach out to Tenfold leadership:::

Account Management (Sales, Licenses, Prospects) - Dan Sincavage: +1 (978) 944-2096
Billing and Finance (Billing Payment info) -Jeff Cotten: +1 (512) 545-3942
Customer Success (Existing Customers) - Josue Rodriguez: +1 (210) 274-4235
Support Escalations (Technical Support) - Jathan Désir: +1 (512) 334-6963
Executive Leadership (If none of the above available) - Sean Pinegar: +1 (402) 690-3344

--Tenfold Executive Leadership Team
Posted Feb 15, 2021 - 16:10 UTC