Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 18, 2025 - 22:00 CDT
Scheduled
We are performing essential updates to the Tenfold Application to improve system performance and enhance our analytics capabilities. To minimize disruption, these changes will take place during off-hours.
EU Schedule: 2025-09-18 22:00:00 EST (Maintenance window in UK/NL - 10:00 PM-3:00 AM EST)
What to Expect: Analytics and Data Purge: To optimize our system and comply with our data retention policies, all call data and analytics older than two years will be permanently purged from the system. Enhanced Analytics: We are updating our analytics engine to provide more comprehensive and optimized data and improve stability and performance. Data in your CRM: Please note that analytics data will be retained within your CRM, but it will no longer be accessible directly through the Tenfold Application for records older than two years. Call Recordings will not be affected. Action Required: If you wish to retain any call data or analytics older than two years, you are responsible for performing your own off-hours backups. This data will be permanently deleted, and we will not be able to retrieve it for you. We appreciate your understanding and cooperation as we work to improve the Tenfold Application.
Posted Sep 10, 2025 - 13:00 CDT
This scheduled maintenance affected: Tenfold Dashboard and Application Functionality (Dashboard).