COVID-19 update from Tenfold
Incident Report for Tenfold
Resolved
This incident has been resolved.
Posted Dec 16, 2021 - 17:27 CST
Monitoring
Dear valued tenfold customer,

We wanted to update you on our preparation for business continuity as a result of the COVID-19 coronavirus. As the impact continues to spread across the globe, we want you to know that we are prepared. We are approaching our business continuity plan across two major areas:

1) Our product and keeping it up and operational for our customers
2) Our people and ensuring our ability to serve our customers.


Product and Infrastructure

As a born-in-the-cloud SaaS company, our infrastructure and cloud operations are secured and operate across multiple geographic zones and world-leading public cloud services to ensure our CTI services are not disrupted. We are vigilantly monitoring the utilization of our platform to ensure as usage ramps as contact centers take on more volume that our product maintains the responsiveness you expect and that we continue delivering our committed service levels.


Our People and Customer Service

Tenfold has a thorough Business Continuity Plan that takes advantage of global support resources to ensure that we will continue to operate 24x7x365 ensuring you can continue your sales and service operations with the support you need from tenfold. We are monitoring the spread of the virus and the impact on our employees, contractors, and partners. We are based in Austin, TX where the impact has been very low so far, but will enact work from home procedures as necessary where our employees are prepared to operate continuously to support you. We have also checked in with all of our critical support partners and reviewed their Business Continuity Plans to ensure our entire supply chain in providing services to our customers is ready to go. Should you have any questions or concerns please do not hesitate to contact us for more information.

If you're looking to increase the number of employees working remotely and handling customer conversations in light of your own business continuity plans tenfold can help. We are assisting many customers with ensuring their employees have the necessary connectivity between their phone systems and data to ensure your customers are well taken care of during any business changes to accommodate this outbreak. Please feel free to contact your Customer Success Manager or CustomerSuccess@Tenfold.com for more information.
Posted Mar 12, 2020 - 09:42 CDT