Status
Welcome to the Tenfold status page. We'll provide status of our services and updates here.
Reports of Latent Call Event Processing & Reporting
Incident Report for Tenfold
Resolved
All latency issues must be normalized now.
Posted 11 months ago. Feb 16, 2018 - 00:13 UTC
Investigating
Tenfold Site Reliability team is investigating reports of intermittent, latent call reporting and UI deployment for a segment of our customers. Our team will be updating our status page as more information is made available.

If you have any questions feel free to reach out to our support team at: e: support@tenfold.com
Posted 11 months ago. Feb 15, 2018 - 22:26 UTC
This incident affected: Chrome Extension.