Status
Welcome to the Tenfold status page. We'll provide status of our services and updates here.
Salesforce CRM API Increased Latency
Incident Report for Tenfold
Resolved
Tenfold engineering has continued to monitor throughout the day for this issue. As there have not been any new occurrences of Salesforce's API latency, this incident will close however Tenfold Operations and Monitoring teams will continue to monitor all aspects of our platform.
Posted Sep 22, 2021 - 21:59 UTC
Monitoring
The issue has been identified as one with the Salesforce CRM API, and we can see that a change has been made on that front, as services are gradually restoring to their fully-functional state. Some customers may need to go to their Tenfold Dashboard -> Company Settings -> CRM and reconnect their Salesforce instance.

We urge you to check that page to see if you or your users have been impacted by this incident. For further details related to this incident, please contact Salesforce via normal support channels.
Posted Sep 22, 2021 - 12:44 UTC
Identified
API latency has begun to decrease without Tenfold intervention. Tenfold is working to further understand this incident.
Posted Sep 22, 2021 - 12:21 UTC
Update
We are continuing to investigate this issue.
Posted Sep 22, 2021 - 11:57 UTC
Investigating
Tenfold automated systems have detected an issue with the Salesforce CRM API. Users may experience issues of persistent loss of functionality and latency to Tenfold CRM services.

Our team is currently investigating, and we will be providing more information as it is made available.

Feel free to subscribe for the most up-to-date notifications here: How to Subscribe
Posted Sep 22, 2021 - 11:56 UTC
This incident affected: API and CRM Integrations (Salesforce).